seopop
【スポンサー広告】

MQL5はMQL4と互換性はありますか?

MQL5のEA(専門家アドバイザー)、指標、スクリプトがMQL4と互換性が
あるかどうかについてはまだ疑問があります。

MQL5が発表された当初の答えは「いいえ」でした。

しかし、生みの親MetaQuotes社は、過去数年間でMQL5とMQL4の2つのプ
ラットフォーム間のこのギャップを埋めることに熱心に取り組んでお
り、調整の必要がほとんど または まったくなく、MQL5とMQL4両者
の非互換性が少なくなっています。

メタクォーツ社は、主にMQL4でのみ利用可能な機能をMQL5に装備する
ことによって、これを実行します。

自動売買のエキスパートアドバイザー(EA)やスクリプトの場合、非
互換性は主に取引業務にあります。

ほとんどのEAはトレーディングロボットであり、MQL4トレーディング
ロボットはMQL5と互換性があるように記録する必要があります。

インジケータについては、若干の変更が必要な場合があります。

しかし、MQL5はインプリメント(実装=「実行する」「実現させる」
など)が難しいインジケータや、MQL4でインプリメントすることが不
可能なインジケータの高度な機能を提供します。

 

結論:

MQL5とMQL4の互換性は 各製品ごとに異なるため
自らデモ口座などでバックテストを実行して確かめること。

 

・MT4のEAやインディケーターがMT5で使えないケースがある

・MT4が標準のオンライン証券会社の普及率がまだ高い

・MT5のPCのメモリ消費量の増加

・MT5のプログラマーがまだまだ少ない

 

Metatrader4またはMetatrader5のプログラミング情報が必要な場合は
、各EA販売者やインジケーター開発者に直接メールでお問い合わせし
てください。

 

 

>